PDA

View Full Version : ArcaneLegends.APK now available/Device Requirements



Samhayne
11-13-2012, 01:23 PM
In order to play Arcane Legends on an Android device, you will need one that has:


An ARMv7 device with touchscreen support
Android OS version 2.3 or higher
OpenGL verions 2.0 or higher


Link to the ArcaneLegends.apk is here: https://account.spacetimestudios.com/download/ArcaneLegends.apk

If you have trouble Installing or Updating the Game on your Android device, please see this support article for tips: http://support.spacetimestudios.com/entries/20075762-i-have-trouble-installing-or-updating-the-game-on-my-android