View RSS Feed

WarPain WarSpear

Change of Device Requirements! (-.-)

Rate this Entry
When i download star legends it was compatible, but when i re-visit the play store it not compatibles as messages "Your device is not compatible in this version (in the app)" _

I see the message but nothing happens, after some day it shows effect: the Crash, now i cant play star legends at that time and presents

Sorry i was post in blogs, not suggestions and for wrong grammar, too (if there's some)

Submit "Change of Device Requirements! (-.-)" to Digg Submit "Change of Device Requirements! (-.-)" to del.icio.us Submit "Change of Device Requirements! (-.-)" to StumbleUpon Submit "Change of Device Requirements! (-.-)" to Google

Updated 12-22-2012 at 11:32 AM by WarPain WarSpear

Tags: None Add / Edit Tags
Categories
Uncategorized

Comments

  1. Samhayne's Avatar
    Hey WarSpear,

    Our apologies that your device is no longer supported. It's the pace of technology. You can read more about the change here: [url]http://www.spacetimestudios.com/showthread.php?70041-Keeping-Pace-with-Technology[/url]